The node has a reg property, therefore its name should include a unit
address. Also change the name from 'usb_id_nopull' to 'adc-chan', which
is the preferred name for ADC channel nodes.

Include headers for constants used in the example.

Signed-off-by: Matthias Kaehlcke <m...@chromium.org>
Reviewed-by: Douglas Anderson <diand...@chromium.org>
---
Changes in v6:
- changed node name to adc-chan@
- added includes for constants used in the example
- updated commit message
- added 'Reviewed-by: Douglas Anderson <diand...@chromium.org>' tag

Changes in v5:
- patch added to the series
---
 .../devicetree/bindings/iio/adc/qcom,spmi-vadc.txt          | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

diff --git a/Documentation/devicetree/bindings/iio/adc/qcom,spmi-vadc.txt 
b/Documentation/devicetree/bindings/iio/adc/qcom,spmi-vadc.txt
index b3c86f4ac7cdb..c81993f8d8c39 100644
--- a/Documentation/devicetree/bindings/iio/adc/qcom,spmi-vadc.txt
+++ b/Documentation/devicetree/bindings/iio/adc/qcom,spmi-vadc.txt
@@ -140,6 +140,10 @@ VADC_GND_REF and VADC_VDD_VADC.
 
 Example:
 
+#include <dt-bindings/iio/qcom,spmi-vadc.h>
+#include <linux/irq.h>
+/* ... */
+
        /* VADC node */
        pmic_vadc: vadc@3100 {
                compatible = "qcom,spmi-vadc";
@@ -151,7 +155,7 @@ Example:
                io-channel-ranges;
 
                /* Channel node */
-               usb_id_nopull {
+               adc-chan@VADC_LR_MUX10_USB_ID {
                        reg = <VADC_LR_MUX10_USB_ID>;
                        qcom,decimation = <512>;
                        qcom,ratiometric;
-- 
2.19.1.930.g4563a0d9d0-goog

Reply via email to