Hi Arnd, On Tue, Jan 15, 2019 at 4:19 PM Arnd Bergmann <a...@arndb.de> wrote: > On Tue, Jan 15, 2019 at 4:01 PM Arnd Bergmann <a...@arndb.de> wrote: > > On Mon, Jan 14, 2019 at 4:59 AM Michael Ellerman <m...@ellerman.id.au> > > wrote: > > > Arnd Bergmann <a...@arndb.de> writes: > > > > arch/m68k/kernel/syscalls/syscall.tbl | 11 +++++++++++ > > > > arch/mips/kernel/syscalls/syscall_o32.tbl | 11 +++++++++++ > > > > arch/powerpc/kernel/syscalls/syscall.tbl | 12 ++++++++++++ > > > > > > I have some changes I'd like to make to our syscall table that will > > > clash with this. > > > > > > I'll try and send them today. > > > > Ok. Are those for 5.0 or 5.1? If they are intended for 5.0, it would be > > nice for me to have a branch based on 5.0-rc1 that I can put > > the other patches on top of. > > There is also another change that I considered: > > At the end of my series, we have a lot of entries like > > 245 32 clock_settime sys_clock_settime32 > 245 64 clock_settime sys_clock_settime > 245 spu clock_settime sys_clock_settime > > which could be folded into > > 245 32 clock_settime sys_clock_settime32 > 245 spu64 clock_settime sys_clock_settime > > if we just add another option to the ABI field. Any thoughts on > that?
So "spu64" would mean "spu + 64"? That makes it more difficult to read, and to grep. What about allowing multiple ABIs, separated by commas? So that line would become: 245 spu,64 clock_settime sys_clock_settime Gr{oetje,eeting}s, Geert -- Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- ge...@linux-m68k.org In personal conversations with technical people, I call myself a hacker. But when I'm talking to journalists I just say "programmer" or something like that. -- Linus Torvalds