On Thu, 2019-02-07 at 18:40 -0600, Gustavo A. R. Silva wrote:
> Make use of the struct_size() helper instead of an open-coded version
> in order to avoid any potential type mistakes, in particular in the
> context in which this code is being used.
> 
> So, change the following form:
> 
> sizeof(*ev) + ev->num_hndl * sizeof(struct hci_comp_pkts_info)
> 
>  to :
> 
> struct_size(ev, handles, ev->num_hndl)
> 
> This code was detected with the help of Coccinelle.
[]
> diff --git a/net/bluetooth/hci_event.c b/net/bluetooth/hci_event.c
[]
> @@ -3556,8 +3556,8 @@ static void hci_num_comp_pkts_evt(struct hci_dev *hdev, 
> struct sk_buff *skb)
>               return;
>       }
>  
> -     if (skb->len < sizeof(*ev) || skb->len < sizeof(*ev) +
> -         ev->num_hndl * sizeof(struct hci_comp_pkts_info)) {
> +     if (skb->len < sizeof(*ev) ||
> +         skb->len < struct_size(ev, handles, ev->num_hndl)) {
>               BT_DBG("%s bad parameters", hdev->name);
>               return;
>       }
> @@ -3644,8 +3644,8 @@ static void hci_num_comp_blocks_evt(struct hci_dev 
> *hdev, struct sk_buff *skb)
>               return;
>       }
>  
> -     if (skb->len < sizeof(*ev) || skb->len < sizeof(*ev) +
> -         ev->num_hndl * sizeof(struct hci_comp_blocks_info)) {
> +     if (skb->len < sizeof(*ev) ||
> +         skb->len < struct_size(ev, handles, ev->num_hndl)) {

Unless these are in a real fast path where skb->len < sizeof(*ev)
is pretty likely, it seems a bit redundant as the multiplication
is pretty cheap and num_hndl is unsigned (actually __u8)

This could/should be simply

        if (skb->len < struct_size(...))


Reply via email to