Use the of_property_count_elems_of_size() helper instead of open-coding
it's logic. As a bonus this will now error out if the "reg" property
values use an incorrect size (anything other than sizeof(u32)).

Signed-off-by: Martin Blumenstingl <martin.blumensti...@googlemail.com>
---
 drivers/mtd/nand/raw/meson_nand.c | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)

diff --git a/drivers/mtd/nand/raw/meson_nand.c 
b/drivers/mtd/nand/raw/meson_nand.c
index c1a6af57dab5..9a6023638101 100644
--- a/drivers/mtd/nand/raw/meson_nand.c
+++ b/drivers/mtd/nand/raw/meson_nand.c
@@ -1233,10 +1233,7 @@ meson_nfc_nand_chip_init(struct device *dev,
        int ret, i;
        u32 tmp, nsels;
 
-       if (!of_get_property(np, "reg", &nsels))
-               return -EINVAL;
-
-       nsels /= sizeof(u32);
+       nsels = of_property_count_elems_of_size(np, "reg", sizeof(u32));
        if (!nsels || nsels > MAX_CE_NUM) {
                dev_err(dev, "invalid register property size\n");
                return -EINVAL;
-- 
2.21.0

Reply via email to