Hi Boris and Lorenzo, From: Boris Brezillon <boris.brezil...@collabora.com> Date: Tue, Apr 16, 2019 at 09:05:40
> On Tue, 16 Apr 2019 09:58:33 +0200 > Lorenzo Bianconi <lorenzo.biancon...@gmail.com> wrote: > > > > > > > On Mon, 15 Apr 2019 21:19:41 +0200 > > > Vitor Soares <vitor.soa...@synopsys.com> wrote: > > > > > > > For today the st_lsm6dsx driver support lsm6dso sensor only in > > > > spi and i2c mode. > > > > > > > > The lsm6dso is also i3c capable so lets give i3c support to it. > > > > > > > > Signed-off-by: Vitor Soares <vitor.soa...@synopsys.com> > > > > --- > > > > drivers/iio/imu/st_lsm6dsx/Kconfig | 8 +++- > > > > drivers/iio/imu/st_lsm6dsx/Makefile | 1 + > > > > drivers/iio/imu/st_lsm6dsx/st_lsm6dsx_i3c.c | 67 > > > > +++++++++++++++++++++++++++++ > > > > 3 files changed, 75 insertions(+), 1 deletion(-) > > > > create mode 100644 drivers/iio/imu/st_lsm6dsx/st_lsm6dsx_i3c.c > > > > > > > > diff --git a/drivers/iio/imu/st_lsm6dsx/Kconfig > > > > b/drivers/iio/imu/st_lsm6dsx/Kconfig > > > > index 094fd00..1ab9bbf 100644 > > > > --- a/drivers/iio/imu/st_lsm6dsx/Kconfig > > > > +++ b/drivers/iio/imu/st_lsm6dsx/Kconfig > > > > @@ -1,11 +1,12 @@ > > > > > > > > config IIO_ST_LSM6DSX > > > > tristate "ST_LSM6DSx driver for STM 6-axis IMU MEMS sensors" > > > > - depends on (I2C || SPI) > > > > + depends on (I2C || SPI || I3C) > > > > select IIO_BUFFER > > > > select IIO_KFIFO_BUF > > > > select IIO_ST_LSM6DSX_I2C if (I2C) > > > > select IIO_ST_LSM6DSX_SPI if (SPI_MASTER) > > > > + select IIO_ST_LSM6DSX_I3C if (I3C) > > > > help > > > > Say yes here to build support for STMicroelectronics LSM6DSx imu > > > > sensor. Supported devices: lsm6ds3, lsm6ds3h, lsm6dsl, lsm6dsm, > > > > @@ -23,3 +24,8 @@ config IIO_ST_LSM6DSX_SPI > > > > tristate > > > > depends on IIO_ST_LSM6DSX > > > > select REGMAP_SPI > > > > + > > > > +config IIO_ST_LSM6DSX_I3C > > > > + tristate > > > > + depends on IIO_ST_LSM6DSX > > > > + select REGMAP_I3C > > > > diff --git a/drivers/iio/imu/st_lsm6dsx/Makefile > > > > b/drivers/iio/imu/st_lsm6dsx/Makefile > > > > index e5f733c..c676965 100644 > > > > --- a/drivers/iio/imu/st_lsm6dsx/Makefile > > > > +++ b/drivers/iio/imu/st_lsm6dsx/Makefile > > > > @@ -4,3 +4,4 @@ st_lsm6dsx-y := st_lsm6dsx_core.o st_lsm6dsx_buffer.o \ > > > > obj-$(CONFIG_IIO_ST_LSM6DSX) += st_lsm6dsx.o > > > > obj-$(CONFIG_IIO_ST_LSM6DSX_I2C) += st_lsm6dsx_i2c.o > > > > obj-$(CONFIG_IIO_ST_LSM6DSX_SPI) += st_lsm6dsx_spi.o > > > > +obj-$(CONFIG_IIO_ST_LSM6DSX_I3C) += st_lsm6dsx_i3c.o > > > > diff --git a/drivers/iio/imu/st_lsm6dsx/st_lsm6dsx_i3c.c > > > > b/drivers/iio/imu/st_lsm6dsx/st_lsm6dsx_i3c.c > > > > new file mode 100644 > > > > index 0000000..2df5e70 > > > > --- /dev/null > > > > +++ b/drivers/iio/imu/st_lsm6dsx/st_lsm6dsx_i3c.c > > > > @@ -0,0 +1,67 @@ > > > > +// SPDX-License-Identifier: GPL-2.0 > > > > +/* > > > > + * Copyright (c) 2018 Synopsys, Inc. and/or its affiliates. > > > > + * > > > > + * Author: Vitor Soares <vitor.soa...@synopsys.com> > > > > + */ > > > > + > > > > +#include <linux/kernel.h> > > > > +#include <linux/module.h> > > > > +#include <linux/i3c/device.h> > > > > +#include <linux/i3c/master.h> > > > > +#include <linux/slab.h> > > > > +#include <linux/of.h> > > > > +#include <linux/regmap.h> > > > > + > > > > +#include "st_lsm6dsx.h" > > > > + > > > > +#define NAME_SIZE 32 > > > > + > > > > +struct st_lsm6dsx_i3c_data { > > > > + char name[NAME_SIZE]; > > > > > > const char *name; I will fix this next patch. > > > > > > > + enum st_lsm6dsx_hw_id id; > > > > +}; > > > > + > > > > +static const struct st_lsm6dsx_i3c_data hw_data[] = { > > > > > > No need to make it an array, and it should probably be named > > > st_lsm6dso_data not hw_data. > > > > I guess it will be used even for future devices so I would prefer to > > make it an array with a 'general' name The idea is that one. Are you ok with hw_data name? Should I add the lsm6dsr support here or send in a different patch? > > I find it more error-prone to reference an array with an opaque index > number than reference an instance with a name that clearly reflects > what HW it describes (see the I3C_DEVICE() entry at the end of the > driver), but okay. I will address this next version. > > > > > Regards, > > Lorenzo > > > > > > > > > + { ST_LSM6DSO_DEV_NAME, ST_LSM6DSO_ID }, > > > > +}; > > > > + > > > > +static const struct regmap_config st_lsm6dsx_i3c_regmap_config = { > > > > + .reg_bits = 8, > > > > + .val_bits = 8, > > > > +}; > > > > + > > > > +static int st_lsm6dsx_i3c_probe(struct i3c_device *i3cdev) > > > > +{ > > > > + const struct i3c_device_id *id = i3c_get_device_id(i3cdev); > > > > > > i3c_device_match_id(i3cdev, > > > > > > st_lsm6dsx_i3c_ids); > > > > > > > + const struct st_lsm6dsx_i3c_data *hw_data = id->data; > > > > + struct regmap *regmap; > > > > + > > > > + regmap = devm_regmap_init_i3c(i3cdev, > > > > &st_lsm6dsx_i3c_regmap_config); > > > > + if (IS_ERR(regmap)) { > > > > + dev_err(&i3cdev->dev, "Failed to register i3c regmap > > > > %d\n", > > > > + (int)PTR_ERR(regmap)); > > > > + return PTR_ERR(regmap); > > > > + } > > > > + > > > > + return st_lsm6dsx_probe(&i3cdev->dev, 0, hw_data->id, > > > > + hw_data->name, regmap); > > > > +} > > > > + > > > > + > > > > +static const struct i3c_device_id st_lsm6dsx_i3c_ids[] = { > > > > + I3C_DEVICE(0x0104, 0x006C, &hw_data[0]), > > > > + { /* sentinel */ }, > > > > +}; > > > > +MODULE_DEVICE_TABLE(i3c, st_lsm6dsx_i3c_ids); > > > > + > > > > +static struct i3c_driver st_lsm6dsx_driver = { > > > > + .driver.name = "st_lsm6dsx_i3c", > > > > + .probe = st_lsm6dsx_i3c_probe, > > > > + .id_table = st_lsm6dsx_i3c_ids, > > > > > > You should probably set the pm_ops here (st_lsm6dsx_pm_ops). > > > > > > > +}; > > > > +module_i3c_driver(st_lsm6dsx_driver); > > > > + > > > > +MODULE_AUTHOR("Vitor Soares <vitor.soa...@synopsys.com>"); > > > > +MODULE_DESCRIPTION("STMicroelectronics st_lsm6dsx i3c driver"); > > > > +MODULE_LICENSE("GPL v2"); > > > > + > > > > > > You can remove this blank line. > > > > > > > Best regards, Vitor Soares