On 16/05/2019 08:10:34+0000, claudiu.bez...@microchip.com wrote:
> >> @@ -69,10 +80,11 @@ static int clk_slow_osc_prepare(struct clk_hw *hw)
> >>    void __iomem *sckcr = osc->sckcr;
> >>    u32 tmp = readl(sckcr);
> >>  
> >> -  if (tmp & (AT91_SCKC_OSC32BYP | AT91_SCKC_OSC32EN))
> >> +  if (tmp & (AT91_SCKC_OSC32BYP(osc->bits) |
> >> +             AT91_SCKC_OSC32EN(osc->bits)))
> > 
> > I still find that:
> > 
> >     if (tmp & (osc->bits->cr_osc32byp | osc->bits->cr_osc32en))
> > 
> > would be shorter and easier to read and still fits on one line.
> 
> Agree, but I thought to use the same interface everywhere. Anyway, tell me
> if you want to resend with these changes.
> 
My comment applies to all the AT91_SCKC_.*() macros. I don't feel that
the macros make the code clearer, accessing bits->cr_.* is self
documenting enough (and makes the code shorter).

-- 
Alexandre Belloni, Bootlin
Embedded Linux and Kernel engineering
https://bootlin.com

Reply via email to