On Friday 24 August 2007 18:06, Christoph Lameter wrote: > On Fri, 24 Aug 2007, Satyam Sharma wrote: > > But if people do seem to have a mixed / confused notion of atomicity > > and barriers, and if there's consensus, then as I'd said earlier, I > > have no issues in going with the consensus (eg. having API variants). > > Linus would be more difficult to convince, however, I suspect :-) > > The confusion may be the result of us having barrier semantics in > atomic_read. If we take that out then we may avoid future confusions.
I think better name may help. Nuke atomic_read() altogether. n = atomic_value(x); // doesnt hint as strongly at reading as "atomic_read" n = atomic_fetch(x); // yes, we _do_ touch RAM n = atomic_read_uncached(x); // or this How does that sound? -- vda - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/