i and j are used everywhere with unsigned types.
Cleanup and prettify the code a bit.

Introduce syms_nr for readability and as a preparation for allocating an
array of vDSO entries that will be needed for creating two vdso .so's:
one for host tasks and another for processes inside time namespace.

Co-developed-by: Andrei Vagin <ava...@openvz.org>
Signed-off-by: Andrei Vagin <ava...@openvz.org>
Signed-off-by: Dmitry Safonov <d...@arista.com>
---
 arch/x86/entry/vdso/vdso2c.h | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)

diff --git a/arch/x86/entry/vdso/vdso2c.h b/arch/x86/entry/vdso/vdso2c.h
index a20b134de2a8..80be339ee93e 100644
--- a/arch/x86/entry/vdso/vdso2c.h
+++ b/arch/x86/entry/vdso/vdso2c.h
@@ -13,7 +13,7 @@ static void BITSFUNC(go)(void *raw_addr, size_t raw_len,
        unsigned long load_size = -1;  /* Work around bogus warning */
        unsigned long mapping_size;
        ELF(Ehdr) *hdr = (ELF(Ehdr) *)raw_addr;
-       int i;
+       unsigned int i, syms_nr;
        unsigned long j;
        ELF(Shdr) *symtab_hdr = NULL, *strtab_hdr, *secstrings_hdr,
                *alt_sec = NULL;
@@ -86,11 +86,10 @@ static void BITSFUNC(go)(void *raw_addr, size_t raw_len,
        strtab_hdr = raw_addr + GET_LE(&hdr->e_shoff) +
                GET_LE(&hdr->e_shentsize) * GET_LE(&symtab_hdr->sh_link);
 
+       syms_nr = GET_LE(&symtab_hdr->sh_size) / 
GET_LE(&symtab_hdr->sh_entsize);
        /* Walk the symbol table */
-       for (i = 0;
-            i < GET_LE(&symtab_hdr->sh_size) / GET_LE(&symtab_hdr->sh_entsize);
-            i++) {
-               int k;
+       for (i = 0; i < syms_nr; i++) {
+               unsigned int k;
                ELF(Sym) *sym = raw_addr + GET_LE(&symtab_hdr->sh_offset) +
                        GET_LE(&symtab_hdr->sh_entsize) * i;
                const char *sym_name = raw_addr +
-- 
2.22.0

Reply via email to