This patch alters the for loop iteration scheme in zpci_map_resources
to make it more usual. Thus, the patch generalizes the style for
PCI_IOV_RESOURCES iteration and improves readability.

Signed-off-by: Denis Efremov <efre...@linux.com>
---
 arch/s390/pci/pci.c | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/arch/s390/pci/pci.c b/arch/s390/pci/pci.c
index b0e3b9a0e488..c7fea9bea8cb 100644
--- a/arch/s390/pci/pci.c
+++ b/arch/s390/pci/pci.c
@@ -431,13 +431,13 @@ static void zpci_map_resources(struct pci_dev *pdev)
        }
 
 #ifdef CONFIG_PCI_IOV
-       i = PCI_IOV_RESOURCES;
+       for (i = 0; i < PCI_SRIOV_NUM_BARS; i++) {
+               int bar = i + PCI_IOV_RESOURCES;
 
-       for (; i < PCI_SRIOV_NUM_BARS + PCI_IOV_RESOURCES; i++) {
-               len = pci_resource_len(pdev, i);
+               len = pci_resource_len(pdev, bar);
                if (!len)
                        continue;
-               pdev->resource[i].parent = &iov_res;
+               pdev->resource[bar].parent = &iov_res;
        }
 #endif
 }
-- 
2.21.0

Reply via email to