> Some processes dont't want to be killed early, but in "Action Required"
> case, those also may be killed by BUS_MCEERR_AO when sharing memory
> with other which is accessing the fail memory.
> And sending SIGBUS with BUS_MCEERR_AO for action required error is
> strange, so ignore the non-current processes here.
>
> Suggested-by: Naoya Horiguchi <naoya.horigu...@nec.com>
> Signed-off-by: Wetp Zhang <wetp...@linux.alibaba.com>
> ---
>  mm/memory-failure.c | 15 +++++++++------
>  1 file changed, 9 insertions(+), 6 deletions(-)
>
> diff --git a/mm/memory-failure.c b/mm/memory-failure.c
> index a96364be8ab4..dd3862fcf2e9 100644
> --- a/mm/memory-failure.c
> +++ b/mm/memory-failure.c
> @@ -210,14 +210,17 @@ static int kill_proc(struct to_kill *tk, unsigned long 
> pfn, int flags)
>  {
>         struct task_struct *t = tk->tsk;
>         short addr_lsb = tk->size_shift;
> -       int ret;
> +       int ret = 0;
>
> -       pr_err("Memory failure: %#lx: Sending SIGBUS to %s:%d due to hardware 
> memory corruption\n",
> -               pfn, t->comm, t->pid);
> +       if ((t->mm == current->mm) || !(flags & MF_ACTION_REQUIRED))
> +               pr_err("Memory failure: %#lx: Sending SIGBUS to %s:%d due to 
> hardware memory corruption\n",
> +                       pfn, t->comm, t->pid);

Maybe we can generalize the message condition for better readability.
Thought a bit but did not get any other idea.
>
> -       if ((flags & MF_ACTION_REQUIRED) && t->mm == current->mm) {
> -               ret = force_sig_mceerr(BUS_MCEERR_AR, (void __user *)tk->addr,
> -                                      addr_lsb);
> +       if (flags & MF_ACTION_REQUIRED) {
> +               if (t->mm == current->mm)
> +                       ret = force_sig_mceerr(BUS_MCEERR_AR,
> +                                        (void __user *)tk->addr, addr_lsb);
> +               /* send no signal to non-current processes */
>         } else {
>                 /*
>                  * Don't use force here, it's convenient if the signal
> --

Looks good to me.
Acked-by: Pankaj Gupta <pankaj.gupta.li...@gmail.com>

Reply via email to