--

On Wed, 17 Oct 2007, Daniel Walker wrote:

> On Wed, 2007-10-17 at 11:10 -0400, Steven Rostedt wrote:
>
> > > >
> > > >  #define read_seqbegin_irqsave(lock, flags)                     \
> > > > -do {                                                           \
> > > > +({                                                             \
> > > >         flags = PICK_SEQ_OP_RET(__read_seqbegin_irqsave_raw,    \
> > > >                 __read_seqbegin_irqsave, lock);                 \
> > > > -} while (0)
> > > > +       read_seqbegin(lock);                                    \
> > > > +})
> >
> > Yes, definitely the raw and unraw functions should be called
> > local_irqsave_raw or something else that makes this obvious to what it
> > is doing.
>
> Hmm.. I'm not sure what else to name them .. Since it's in the seqlock.h
> I don't think it should be called anything "local_irq*" .. It could be
> seq_irqsave_{raw} .

Hmm, what about a __seq_irqsave_raw and __seq_nop?

That way it spells out that irqs are NOT touched if it is not a raw lock.

-- Steve

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to