From: Bartosz Golaszewski <bgolaszew...@baylibre.com> Regular krealloc() obviously can't work with managed memory. This series implements devm_krealloc() and adds the first user with hope that this helper will be adopted by other drivers currently using non-managed krealloc().
Some additional changes to the code modified by main patches are included. v1 -> v2: - remove leftover call to hwmon_device_unregister() from pmbus_core.c - add a patch extending devm_kmalloc() to handle zero size case - use WARN_ON() instead of WARN_ONCE() in devm_krealloc() when passed a pointer to non-managed memory - correctly handle the case when devm_krealloc() is passed a pointer to memory in .rodata (potentially returned by devm_kstrdup_const()) - correctly handle ZERO_SIZE_PTR passed as the ptr argument in devm_krealloc() Bartosz Golaszewski (6): devres: remove stray space from devm_kmalloc() definition devres: move the size check from alloc_dr() into a separate function device: remove 'extern' attribute from function prototypes in device.h devres: handle zero size in devm_kmalloc() devres: provide devm_krealloc() hwmon: pmbus: use more devres helpers .../driver-api/driver-model/devres.rst | 1 + drivers/base/devres.c | 75 +++++- drivers/hwmon/pmbus/pmbus_core.c | 28 +-- include/linux/device.h | 225 +++++++++--------- 4 files changed, 187 insertions(+), 142 deletions(-) -- 2.26.1