Le 27/08/2020 à 17:00, Christoph Hellwig a écrit :
Stop providing the possibility to override the address space using
set_fs() now that there is no need for that any more.

Signed-off-by: Christoph Hellwig <h...@lst.de>
---
  arch/powerpc/Kconfig                   |  1 -
  arch/powerpc/include/asm/processor.h   |  7 ---
  arch/powerpc/include/asm/thread_info.h |  5 +--
  arch/powerpc/include/asm/uaccess.h     | 62 ++++++++------------------
  arch/powerpc/kernel/signal.c           |  3 --
  arch/powerpc/lib/sstep.c               |  6 +--
  6 files changed, 22 insertions(+), 62 deletions(-)

diff --git a/arch/powerpc/include/asm/uaccess.h 
b/arch/powerpc/include/asm/uaccess.h
index 7fe3531ad36a77..39727537d39701 100644
--- a/arch/powerpc/include/asm/uaccess.h
+++ b/arch/powerpc/include/asm/uaccess.h
@@ -8,62 +8,36 @@
  #include <asm/extable.h>
  #include <asm/kup.h>
-/*
- * The fs value determines whether argument validity checking should be
- * performed or not.  If get_fs() == USER_DS, checking is performed, with
- * get_fs() == KERNEL_DS, checking is bypassed.
- *
- * For historical reasons, these macros are grossly misnamed.
- *
- * The fs/ds values are now the highest legal address in the "segment".
- * This simplifies the checking in the routines below.
- */
-
-#define MAKE_MM_SEG(s)  ((mm_segment_t) { (s) })
-
-#define KERNEL_DS      MAKE_MM_SEG(~0UL)
  #ifdef __powerpc64__
  /* We use TASK_SIZE_USER64 as TASK_SIZE is not constant */
-#define USER_DS                MAKE_MM_SEG(TASK_SIZE_USER64 - 1)
-#else
-#define USER_DS                MAKE_MM_SEG(TASK_SIZE - 1)
-#endif
-
-#define get_fs()       (current->thread.addr_limit)
+#define TASK_SIZE_MAX          TASK_SIZE_USER64
-static inline void set_fs(mm_segment_t fs)
+static inline bool __access_ok(unsigned long addr, unsigned long size)
  {
-       current->thread.addr_limit = fs;
-       /* On user-mode return check addr_limit (fs) is correct */
-       set_thread_flag(TIF_FSCHECK);
+       if (addr >= TASK_SIZE_MAX)
+               return false;
+       /*
+        * This check is sufficient because there is a large enough gap between
+        * user addresses and the kernel addresses.
+        */
+       return size <= TASK_SIZE_MAX;
  }
-
-#define uaccess_kernel() (get_fs().seg == KERNEL_DS.seg)
-#define user_addr_max()        (get_fs().seg)
-
-#ifdef __powerpc64__
-/*
- * This check is sufficient because there is a large enough
- * gap between user addresses and the kernel addresses
- */
-#define __access_ok(addr, size, segment)       \
-       (((addr) <= (segment).seg) && ((size) <= (segment).seg))
-
  #else
+#define TASK_SIZE_MAX          TASK_SIZE
-static inline int __access_ok(unsigned long addr, unsigned long size,
-                       mm_segment_t seg)
+static inline bool __access_ok(unsigned long addr, unsigned long size)
  {
-       if (addr > seg.seg)
-               return 0;
-       return (size == 0 || size - 1 <= seg.seg - addr);
+       if (addr >= TASK_SIZE_MAX)
+               return false;
+       if (size == 0)
+               return false;

__access_ok() was returning true when size == 0 up to now. Any reason to return false now ?

+       return size <= TASK_SIZE_MAX - addr;
  }
-
-#endif
+#endif /* __powerpc64__ */
#define access_ok(addr, size) \
        (__chk_user_ptr(addr),          \
-        __access_ok((__force unsigned long)(addr), (size), get_fs()))
+        __access_ok((unsigned long)(addr), (size)))
/*
   * These are the main single-value transfer routines.  They automatically

Christophe

Reply via email to