Hi,

On Wed, Sep 30, 2020 at 09:11:32PM -0500, Samuel Holland wrote:
> In preparation for adding additional DAIs to this component, convert the
> DAI driver definition to an array. Since this changes all of the lines
> in the definition anyway, let's move it closer to the ops function
> definitions, instead of on the far side of the DAPM arrays. And while
> moving the DAI driver ops, rename the set_fmt hook to match the usual
> naming scheme.
> 
> Give the existing DAI an explicit ID and more meaningful stream names,
> so it will remain unique as more DAIs are added. The AIF widget streams
> must be updated to match.
> 
> Signed-off-by: Samuel Holland <sam...@sholland.org>
> ---
>  sound/soc/sunxi/sun8i-codec.c | 76 +++++++++++++++++++----------------
>  1 file changed, 42 insertions(+), 34 deletions(-)
> 
> diff --git a/sound/soc/sunxi/sun8i-codec.c b/sound/soc/sunxi/sun8i-codec.c
> index 7590c4b04d14..346f699c2e86 100644
> --- a/sound/soc/sunxi/sun8i-codec.c
> +++ b/sound/soc/sunxi/sun8i-codec.c
> @@ -90,16 +90,21 @@
>  #define SUN8I_SYSCLK_CTL_AIF2CLK_SRC_MASK    GENMASK(5, 4)
>  #define SUN8I_SYS_SR_CTRL_AIF1_FS_MASK               GENMASK(15, 12)
>  #define SUN8I_SYS_SR_CTRL_AIF2_FS_MASK               GENMASK(11, 8)
>  #define SUN8I_AIF1CLK_CTRL_AIF1_BCLK_DIV_MASK        GENMASK(12, 9)
>  #define SUN8I_AIF1CLK_CTRL_AIF1_LRCK_DIV_MASK        GENMASK(8, 6)
>  #define SUN8I_AIF1CLK_CTRL_AIF1_WORD_SIZ_MASK        GENMASK(5, 4)
>  #define SUN8I_AIF1CLK_CTRL_AIF1_DATA_FMT_MASK        GENMASK(3, 2)
>  
> +enum {
> +     AIF1,
> +     NAIFS
> +};
> +

It's a bit of a nitpick, but we should have less generic names for the
enums here, maybe prefix it with sun8i_codec like the rest of the driver?

Once fixed,
Acked-by: Maxime Ripard <mrip...@kernel.org>

Maxime

Attachment: signature.asc
Description: PGP signature

Reply via email to