On Thu, Nov 05, 2020 at 03:05:10PM -0800, paul...@kernel.org wrote:
> From: Hui Su <sh_...@163.com>
> 
> This commit updates the documented API of call_rcu() to use the
> rcu_callback_t typedef instead of the open-coded function definition.
> 
> Signed-off-by: Hui Su <sh_...@163.com>
> Signed-off-by: Paul E. McKenney <paul...@kernel.org>
> ---
>  Documentation/RCU/whatisRCU.rst | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
> 
> diff --git a/Documentation/RCU/whatisRCU.rst b/Documentation/RCU/whatisRCU.rst
> index fb3ff76..1a4723f 100644
> --- a/Documentation/RCU/whatisRCU.rst
> +++ b/Documentation/RCU/whatisRCU.rst
> @@ -497,8 +497,7 @@ long -- there might be other high-priority work to be 
> done.
>  In such cases, one uses call_rcu() rather than synchronize_rcu().
>  The call_rcu() API is as follows::
>  
> -     void call_rcu(struct rcu_head * head,
> -                   void (*func)(struct rcu_head *head));
> +     void call_rcu(struct rcu_head *head, rcu_callback_t func);

Personally I much prefer the old form, because now I have to go look up
rcu_callback_t to figure out wtf kind of signature is actually required.

Reply via email to