On Tue, Dec 01, 2020 at 09:48:36PM -0800, Alexei Starovoitov wrote: > On Tue, Dec 1, 2020 at 4:12 AM Brendan Jackman <jackm...@google.com> wrote: > > > > On Sat, Nov 28, 2020 at 05:14:05PM -0800, Alexei Starovoitov wrote: > > > On Fri, Nov 27, 2020 at 05:57:27PM +0000, Brendan Jackman wrote: > > > > The JIT case for encoding atomic ops is about to get more > > > > complicated. In order to make the review & resulting code easier, > > > > let's factor out some shared helpers. > > > > > > > > Signed-off-by: Brendan Jackman <jackm...@google.com> > > > > --- > > > > arch/x86/net/bpf_jit_comp.c | 39 ++++++++++++++++++++++--------------- > > > > 1 file changed, 23 insertions(+), 16 deletions(-) > > > > > > > > diff --git a/arch/x86/net/bpf_jit_comp.c b/arch/x86/net/bpf_jit_comp.c > > > > index 94b17bd30e00..a839c1a54276 100644 > > > > --- a/arch/x86/net/bpf_jit_comp.c > > > > +++ b/arch/x86/net/bpf_jit_comp.c > > > > @@ -702,6 +702,21 @@ static void emit_modrm_dstoff(u8 **pprog, u32 r1, > > > > u32 r2, int off) > > > > *pprog = prog; > > > > } > > > > > > > > +/* > > > > + * Emit a REX byte if it will be necessary to address these registers > > > > > > What is "REX byte" ? > > > May be rename it to maybe_emit_mod() ? > > > > Er, this is the REX prefix as described in > > https://wiki.osdev.org/X86-64_Instruction_Encoding#REX_prefix > > > > Would maybe_emit_mod be accurate? In my mind "mod" is a field in the > > ModR/M byte which comes _after_ the opcode. Before developing this > > patchset I knew almost nothing about x86, so maybe I'm missing something > > about the general terminology? > > I wrote the JIT without looking into the manual and without studying > the terminology. > Why? Because it was not necessary. I still don't see a reason why > that obscure terminology needs to be brought in into the code. > 'mod' to me is a 'modifier'. Nothing to do with intel's modrm thing.
OK, calling it maybe_emit_mod(pprog, dst_reg, src_reg)