On 03/12/2020 09:14, Christoph Hellwig wrote:
>> @@ -1077,6 +1077,20 @@ void iov_iter_advance(struct iov_iter *i, size_t size)
>>              i->count -= size;
>>              return;
>>      }
>> +    if (iov_iter_is_bvec(i)) {
>> +            struct bvec_iter bi;
>> +
>> +            bi.bi_size = i->count;
>> +            bi.bi_bvec_done = i->iov_offset;
>> +            bi.bi_idx = 0;
>> +            bvec_iter_advance(i->bvec, &bi, size);
>> +
>> +            i->bvec += bi.bi_idx;
>> +            i->nr_segs -= bi.bi_idx;
>> +            i->count = bi.bi_size;
>> +            i->iov_offset = bi.bi_bvec_done;
>> +            return;
>> +    }
>>      iterate_and_advance(i, size, v, 0, 0, 0)
> 
> I like the idea, but whu not avoid the on-stack bvec_iter and just
> open code this entirely using a new helper?  E.g.

It's inlined and the on-stack iter is completely optimised out. Frankly,
I'd rather not open-code bvec_iter_advance(), at least for this chunk to
be findable from bvec.h, e.g. grep bvec_iter and bvec_for_each. Though,
I don't like myself that preamble/postamble.

> 
> static void bio_iov_iter_advance(struct iov_iter *i, size_t bytes)
> {
>       unsigned int cnt;
> 
>       i->count -= bytes;
> 
>       bytes += i->iov_offset;
>       for (cnt = 0; bytes && bytes >= i->bvec[cnt].bv_len; cnt++)
>               bytes -= i->bvec[cnt].bv_len;
>       i->iov_offset = bytes;
> 
>       i->bvec += cnt;
>       i->nr_segs -= cnt;
> }
> 

-- 
Pavel Begunkov

Reply via email to