On Fri, Dec 18, 2020 at 11:12:05PM +0900, Masami Hiramatsu wrote: > @@ -467,8 +489,8 @@ static int arch_copy_kprobe(struct kprobe *p) > */ > len = prepare_boost(buf, p, &insn); > > - /* Check whether the instruction modifies Interrupt Flag or not */ > - p->ainsn.if_modifier = is_IF_modifier(buf); > + /* Analyze the opcode and set resume flags */ > + set_resume_flags(p, &insn);
So this function wants to be called something like analyze_insn() or so then? set_resume_flags() is kinda misleading as a name. Thx. -- Regards/Gruss, Boris. https://people.kernel.org/tglx/notes-about-netiquette