On Wed, Jan 13, 2021 at 10:18:09PM -0800, Dan Williams wrote: > On Wed, Jan 13, 2021 at 5:50 PM HORIGUCHI NAOYA(堀口 直也) > <naoya.horigu...@nec.com> wrote: > > > > On Wed, Jan 13, 2021 at 04:43:32PM -0800, Dan Williams wrote: > > > The conversion to move pfn_to_online_page() internal to > > > soft_offline_page() missed that the get_user_pages() reference taken by > > > the madvise() path needs to be dropped when pfn_to_online_page() fails. > > > Note the direct sysfs-path to soft_offline_page() does not perform a > > > get_user_pages() lookup. > > > > > > When soft_offline_page() is handed a pfn_valid() && > > > !pfn_to_online_page() pfn the kernel hangs at dax-device shutdown due to > > > a leaked reference. > > > > > > Fixes: feec24a6139d ("mm, soft-offline: convert parameter to pfn") > > > Cc: Andrew Morton <a...@linux-foundation.org> > > > Cc: Naoya Horiguchi <nao.horigu...@gmail.com> > > > Cc: Michal Hocko <mho...@kernel.org> > > > Reviewed-by: David Hildenbrand <da...@redhat.com> > > > Reviewed-by: Oscar Salvador <osalva...@suse.de> > > > Cc: <sta...@vger.kernel.org> > > > Signed-off-by: Dan Williams <dan.j.willi...@intel.com> > > > > I'm OK if we don't have any other better approach, but the proposed changes > > make code a little messy, and I feel that get_user_pages() might be the > > right place to fix. Is get_user_pages() expected to return struct page with > > holding refcount for offline valid pages? I thought that such pages are > > only used by drivers for dax-devices, but that might be wrong. Can I ask for > > a little more explanation from this perspective? > > The motivation for ZONE_DEVICE is to allow get_user_pages() for "offline" > pfns.
I missed this point, thank you. > > soft_offline_page() wants to only operate on "online" pfns. Right. > > get_user_pages() on a dax-mapping returns an "offline" ZONE_DEVICE page. OK. > > When pfn_to_online_page() fails the get_user_pages() reference needs > to be dropped. The background is clear to me, and I agree with this patch. Reviewed-by: Naoya Horiguchi <naoya.horigu...@nec.com> > > To be honest I dislike the entire flags based scheme for communicating > the fact that page reference obtained by madvise needs to be dropped > later. I'd rather pass a non-NULL 'struct page *' than redo > pfn_to_page() conversions in the leaf functions, but that's a much > larger change. As Oscar mentions in another email, removing MF_COUNT_INCREASED was recently discussed and rejected. I think that if pfn-page conversion layer is somehow factored out from soft/hard offline handler, code would be more readable/maintainable. Thanks, Naoya Horiguchi