> -----Original Message-----
> From: Andrew Lunn <and...@lunn.ch>
> Sent: Wednesday, March 10, 2021 5:51 PM
> To: Stefan Chulski <stef...@marvell.com>
> Cc: net...@vger.kernel.org; thomas.petazz...@bootlin.com;
> da...@davemloft.net; Nadav Haklai <nad...@marvell.com>; Yan
> Markman <ymark...@marvell.com>; linux-kernel@vger.kernel.org;
> k...@kernel.org; li...@armlinux.org.uk; m...@semihalf.com;
> rmk+ker...@armlinux.org.uk; aten...@kernel.org; rab...@solid-run.com
> Subject: [EXT] Re: [net-next] net: mvpp2: Add reserved port private flag
> configuration
> 
> External Email
> 
> ----------------------------------------------------------------------
> >  static void mvpp2_ethtool_get_strings(struct net_device *netdev, u32
> sset,
> >                                   u8 *data)
> >  {
> >     struct mvpp2_port *port = netdev_priv(netdev);
> >     int i, q;
> >
> > -   if (sset != ETH_SS_STATS)
> > -           return;
> > +   switch (sset) {
> > +   case ETH_SS_STATS:
> > +           for (i = 0; i < ARRAY_SIZE(mvpp2_ethtool_mib_regs); i++) {
> > +                   strscpy(data, mvpp2_ethtool_mib_regs[i].string,
> > +                           ETH_GSTRING_LEN);
> > +                   data += ETH_GSTRING_LEN;
> > +           }
> 
> Hi Stefan
> 
> Maybe rename the existing function to
> mvpp2_ethtool_get_strings_stats() and turn it into a helper. Add a new
> mvpp2_ethtool_get_strings_priv() helper. And a new
> mvpp2_ethtool_get_strings() which just calls the two helpers. 

OK, I can do this.

> Overall the
> patch should be smaller and much easier to review.
> 
>     Andrew

Make it patch series? I can split it to 2/3 patches.
Thanks,
Stefan.

Reply via email to