> diff --git a/tools/testing/selftests/bpf/progs/verifier_bpf_fastcall.c 
> b/tools/testing/selftests/bpf/progs/verifier_bpf_fastcall.c
> index fb4fa465d67c..c26727bef66f 100644
> --- a/tools/testing/selftests/bpf/progs/verifier_bpf_fastcall.c
> +++ b/tools/testing/selftests/bpf/progs/verifier_bpf_fastcall.c
> @@ -660,6 +660,7 @@ __naked void may_goto_interaction_x86_64(void)
>
>  SEC("raw_tp")
>  __arch_arm64
> +__arch_riscv64
>  __log_level(4) __msg("stack depth 24")
>  /* may_goto counter at -24 */
>  __xlated("0: *(u64 *)(r10 -24) =")

[ ... ]

>  __xlated("12: exit")
>  __success
>  __naked void may_goto_interaction_arm64(void)

Now that this test supports both arm64 and riscv64, should the function
name be changed to something more generic like may_goto_interaction()?
The arm64-specific name seems misleading when the test covers multiple
architectures.


---
AI reviewed your patch. Please fix the bug or email reply why it's not a bug.
See: https://github.com/kernel-patches/vmtest/blob/master/ci/claude/README.md

CI run summary: https://github.com/kernel-patches/bpf/actions/runs/29858413299

Reply via email to