On Mon, Aug 06, 2012 at 02:38:23PM -0400, Rik van Riel wrote: > On 08/06/2012 09:56 AM, Rafael Aquini wrote: > > >@@ -846,6 +861,21 @@ static int unmap_and_move(new_page_t get_new_page, > >unsigned long private, > > goto out; > > > > rc = __unmap_and_move(page, newpage, force, offlining, mode); > >+ > >+ if (unlikely(is_balloon_page(newpage)&& > >+ balloon_compaction_enabled())) { > > Could that be collapsed into one movable_balloon_page(newpage) function > call? > Keeping is_balloon_page() as is, and itroducing this new movable_balloon_page() function call, or just doing a plain rename, as Andrew has first suggested?
-- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/