On Sun, Oct 28, 2012 at 04:18:58PM +0900, Akinobu Mita wrote:
>  /**
> + *   prandom32_get_bytes - get the requested number of pseudo-random bytes
> + *   @state: pointer to state structure holding seeded state.
> + *   @buf: where to copy the pseudo-random bytes to
> + *   @bytes: the requested number of bytes
> + *
> + *   This is used for pseudo-randomness with no outside seeding.
> + *   For more random results, use random32_get_bytes().
> + */
> +
> +/**
> + *   random32_get_bytes - get the requested number of pseudo-random bytes
> + *   @buf: where to copy the pseudo-random bytes to
> + *   @bytes: the requested number of bytes
> + */

This naming scheme is going to be very confusing.  If the function is
going to return a pseudo-random number, it *must* have a "prandom"
suffix.  Otherwise some kernel developer, somewhere, will get confused
between get_random_bytes() and random32_get_bytes(), and the result
may be a very embarassing security exposure.

How about prandom32_get_bytes_state() and prandom32_get_bytes() instead?

                                                - Ted
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to