There is no unified subject for this patchset.

Patch 1 is for removing one division operation with multiplication.
Patch 2,3 is for clean-up related to load_balance(), there is improvement
in terms of code size and IMO, readability may be also improved.
Patch 4,5 is for correctness about sched_slice()

Feel free to give a comment for this patchset.

It's based on v3.9-rc4 and top of my previous patchset. But, perhaps,
it may not really depend on my previous patchset. :)

https://lkml.org/lkml/2013/3/26/28
"[PATCH v2 0/6] correct load_balance()"

Thanks.

Joonsoo Kim (5):
  sched: remove one division operation in find_buiest_queue()
  sched: factor out code to should_we_balance()
  sched: clean-up struct sd_lb_stat
  sched: don't consider upper se in sched_slice()
  sched: limit sched_slice if it is more than sysctl_sched_latency

 kernel/sched/fair.c |  347 +++++++++++++++++++++++++--------------------------
 1 file changed, 171 insertions(+), 176 deletions(-)

-- 
1.7.9.5

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to