On Tue, 2013-07-02 at 12:43 +0800, Michael Wang wrote:

> +static int nasty_pull(struct task_struct *p)
> +{
> +     int factor = cpumask_weight(cpu_online_mask);
> +
> +     /*
> +      * Yeah, it's the switching-frequency, could means many wakee or
> +      * rapidly switch, use factor here will just help to automatically
> +      * adjust the loose-degree, so more cpu will lead to more pull.
> +      */
> +     if (p->nr_wakee_switch > factor) {
> +             /*
> +              * wakee is somewhat hot, it needs certain amount of cpu
> +              * resource, so if waker is far more hot, prefer to leave
> +              * it alone.
> +              */
> +             if (current->nr_wakee_switch > (factor * p->nr_wakee_switch))
> +                     return 1;
> +     }
> +
> +     return 0;
> +}

Ew.  I haven't gotten around to test-driving this patchlet, and I see
you haven't gotten around to finding a better name either.  Any other
name will likely have a better chance of flying.

tasks_related()
...
well, nearly any..
tasks_think_wake_affine_sucks_rocks()
..that won't fly either :)

-Mike

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to