Hi all,

Here is the third iteration of the patchset to add better attribute
group support to the driver core and sysfs.

Others have now tested it, and we got 3 more patches fixing a warning
that was showing up when binary attributes were in a group with no
"normal" attributes, and some more helper macros were added and cleaned
up.

I've booted this successfully against 3.11-rc1 with no problems (am
sending these from that machine.)

Ian, I didn't add a DEVICE_PATTR() macro yet, that can come later.  I
considered it, but that would also mean a BUS_PATTR() and the like, which I
guess works, but I hate even a _hint_ of "Hungarian" notation, which this
implies.

Anyone else have a better name for this macro:
        #define DEVICE_PATTR(_name)     &dev_attr_##_name.attr
that they can think of?  It will cut down on the typing done for
attribute lists.

changes from v3:
        - tested by Guenter
        - patches from Oliver added
        - refreshed on 3.11-rc1 (minor fuzz)
        - Ian glanced at them.

changes from v2:
        - actually boots
        - 7th patch added properly
        - added BUS_ATTR, CLASS_ATTR, and DRIVER_ATTR RW and RO macros
          to help with converting code to use attributes properly.

thanks,

greg k-h

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to