Lee Jones <lee.jo...@linaro.org> wrote:
>This patch contains some pretty basic clean-ups in probe() pertaining
>to
>the simplification of error handling and a couple of readability
>adaptions.
>
>Signed-off-by: Lee Jones <lee.jo...@linaro.org>

Hi Lee

Most of this series look fine but I am not that keen on some of this one.

The white space changes are definitely a matter of taste and honestly I don't 
care either way.

The returns are fine when there is no cleanup to do.

GOTOs and a clean unwind of the function is to my eye easier to review than 
unwinding directly after each error.

If reviewing original driver I would probably not bother commenting but for a 
cleanup patch the cleanup wants to be a clear improvement!  

Out of time now so will have to get to the rest of the series sometime soon.  

>---
>drivers/iio/pressure/st_pressure_core.c | 41
>+++++++++++++++------------------
> 1 file changed, 19 insertions(+), 22 deletions(-)
>
>diff --git a/drivers/iio/pressure/st_pressure_core.c
>b/drivers/iio/pressure/st_pressure_core.c
>index 3cf54ed..2893d08 100644
>--- a/drivers/iio/pressure/st_pressure_core.c
>+++ b/drivers/iio/pressure/st_pressure_core.c
>@@ -224,21 +224,23 @@ static const struct iio_trigger_ops
>st_press_trigger_ops = {
> 
> int st_press_common_probe(struct iio_dev *indio_dev)
> {
>-      int err;
>       struct st_sensor_data *pdata = iio_priv(indio_dev);
>+      int irq = pdata->get_irq_data_ready(indio_dev);
>+      int err;
> 
>       indio_dev->modes = INDIO_DIRECT_MODE;
>       indio_dev->info = &press_info;
> 
>       err = st_sensors_check_device_support(indio_dev,
>-                              ARRAY_SIZE(st_press_sensors), st_press_sensors);
>+                                            ARRAY_SIZE(st_press_sensors),
>+                                            st_press_sensors);
>       if (err < 0)
>-              goto st_press_common_probe_error;
>+              return err;
> 
>       pdata->num_data_channels = ST_PRESS_NUMBER_DATA_CHANNELS;
>-      pdata->multiread_bit = pdata->sensor->multi_read_bit;
>-      indio_dev->channels = pdata->sensor->ch;
>-      indio_dev->num_channels = pdata->sensor->num_ch;
>+      pdata->multiread_bit     = pdata->sensor->multi_read_bit;
>+      indio_dev->channels      = pdata->sensor->ch;
>+      indio_dev->num_channels  = pdata->sensor->num_ch;
> 
>       if (pdata->sensor->fs.addr != 0)
>               pdata->current_fullscale = (struct st_sensor_fullscale_avl *)
>@@ -248,32 +250,27 @@ int st_press_common_probe(struct iio_dev
>*indio_dev)
> 
>       err = st_sensors_init_sensor(indio_dev);
>       if (err < 0)
>-              goto st_press_common_probe_error;
>+              return err;
> 
>-      if (pdata->get_irq_data_ready(indio_dev) > 0) {
>+      if (irq > 0) {
>               err = st_press_allocate_ring(indio_dev);
>               if (err < 0)
>-                      goto st_press_common_probe_error;
>+                      return err;
> 
>               err = st_sensors_allocate_trigger(indio_dev,
>-                                                      ST_PRESS_TRIGGER_OPS);
>-              if (err < 0)
>-                      goto st_press_probe_trigger_error;
>+                                                ST_PRESS_TRIGGER_OPS);
>+              if (err < 0) {
>+                      st_press_deallocate_ring(indio_dev);
>+                      return err;
>+              }
>       }
> 
>       err = iio_device_register(indio_dev);
>-      if (err)
>-              goto st_press_device_register_error;
>-
>-      return err;
>-
>-st_press_device_register_error:
>-      if (pdata->get_irq_data_ready(indio_dev) > 0)
>+      if (err && irq > 0) {
>               st_sensors_deallocate_trigger(indio_dev);
>-st_press_probe_trigger_error:
>-      if (pdata->get_irq_data_ready(indio_dev) > 0)
>               st_press_deallocate_ring(indio_dev);
>-st_press_common_probe_error:
>+      }
>+
>       return err;
> }
> EXPORT_SYMBOL(st_press_common_probe);

-- 
Sent from my Android phone with K-9 Mail. Please excuse my brevity.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to