On Wed, 25 Sep 2013 18:44:27 +0800
Jiang Liu <liu...@gmail.com> wrote:

> From: Jiang Liu <jiang....@huawei.com>
> 
> Use macro JUMP_LABEL_TRUE_BRANCH instead of hard-coding for better
> readability.
> 
> Signed-off-by: Jiang Liu <jiang....@huawei.com>
> Cc: Jiang Liu <liu...@gmail.com>
> ---
>  include/linux/jump_label.h | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/include/linux/jump_label.h b/include/linux/jump_label.h
> index a507907..b697fbd 100644
> --- a/include/linux/jump_label.h
> +++ b/include/linux/jump_label.h
> @@ -116,7 +116,8 @@ extern void static_key_slow_dec(struct static_key *key);
>  extern void jump_label_apply_nops(struct module *mod);
>  
>  #define STATIC_KEY_INIT_TRUE ((struct static_key) \
> -     { .enabled = ATOMIC_INIT(1), .entries = (void *)1 })
> +     { .enabled = ATOMIC_INIT(1), \
> +       .entries = (void *)JUMP_LABEL_TRUE_BRANCH })
>  #define STATIC_KEY_INIT_FALSE ((struct static_key) \
>       { .enabled = ATOMIC_INIT(0), .entries = (void *)0 })
>  

Probably should add a comment that there is no
"JUMP_LABEL_FALSE_BRANCH" or maybe we should add one?

-- Steve


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to