On Sat, 2013-11-02 at 19:17 +0530, Govindarajulu Varadarajan wrote:
> Signed-off-by: Govindarajulu Varadarajan <govindarajul...@gmail.com>
[]
> diff --git a/scripts/checkpatch.pl b/scripts/checkpatch.pl
[]
> @@ -3719,7 +3719,7 @@ sub process {
>  # check for needless "if (<foo>) fn(<foo>)" uses
>               if ($prevline =~ /\bif\s*\(\s*($Lval)\s*\)/) {
>                       my $expr = '\s*\(\s*' . quotemeta($1) . '\s*\)\s*;';
> -                     if ($line =~ 
> /\b(kfree|usb_free_urb|debugfs_remove(?:_recursive)?)$expr/) {
> +                     if ($line =~ 
> /\b(kfree|dev_kfree_skb|dev_kfree_skb_any|dev_kfree_skb_irq|usb_free_urb|debugfs_remove(?:_recursive)?)$expr/)
>  {
>                               WARN('NEEDLESS_IF',
>                                    "$1(NULL) is safe this check is probably 
> not required\n" . $hereprev);
>                       }

OK, but I think this is easier to read as

        dev_kfree_skb(?:_skb|_any|_irq)?


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to