* Felipe Contreras <felipe.contre...@gmail.com> wrote:

> We want to calculate the blinks per second, and instead of making it 5 
> (1000 / (3600 / 18)), let's make it 4, so the user can see two blinks 
> per second.

Please use the customary changelog style we use in the kernel:

  " Current code does (A), this has a problem when (B).
    We can improve this doing (C), because (D)."

> Signed-off-by: Felipe Contreras <felipe.contre...@gmail.com>
> ---
>  kernel/panic.c | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/kernel/panic.c b/kernel/panic.c
> index 46e37ff..5a0bdaa 100644
> --- a/kernel/panic.c
> +++ b/kernel/panic.c
> @@ -25,7 +25,7 @@
>  #include <linux/nmi.h>
>  
>  #define PANIC_TIMER_STEP 100
> -#define PANIC_BLINK_SPD 18
> +#define PANIC_BLINK_SPD 4

Please while at it also do another patch that renames it to a sane name, 
PANIC_BLINK_SPEED or so.

>  
>  int panic_on_oops = CONFIG_PANIC_ON_OOPS_VALUE;
>  static unsigned long tainted_mask;
> @@ -147,7 +147,7 @@ void panic(const char *fmt, ...)
>                       touch_nmi_watchdog();
>                       if (i >= i_next) {
>                               i += panic_blink(state ^= 1);
> -                             i_next = i + 3600 / PANIC_BLINK_SPD;
> +                             i_next = i + 1000 / PANIC_BLINK_SPD;

This changes a magic value to another magic value.

>                       }
>                       mdelay(PANIC_TIMER_STEP);
>               }
> @@ -181,7 +181,7 @@ void panic(const char *fmt, ...)
>               touch_softlockup_watchdog();
>               if (i >= i_next) {
>                       i += panic_blink(state ^= 1);
> -                     i_next = i + 3600 / PANIC_BLINK_SPD;
> +                     i_next = i + 1000 / PANIC_BLINK_SPD;

Ditto.

Thanks,

        Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to