On Mon, 31 Jan 2005 13:41:19 +0100, Adrian Bunk <[EMAIL PROTECTED]> wrote:
> notify_lock isn't a good name for a global lock.
> But since it's not used outside of the file, it can be made static.
> 
> Signed-off-by: Adrian Bunk <[EMAIL PROTECTED]>
> 
> --- linux-2.6.11-rc2-mm2-full/drivers/connector/connector.c.old 2005-01-31 
> 13:09:14.000000000 +0100
> +++ linux-2.6.11-rc2-mm2-full/drivers/connector/connector.c     2005-01-31 
> 13:09:28.000000000 +0100
> @@ -41,7 +41,7 @@
> module_param(cn_idx, uint, 0);
> module_param(cn_val, uint, 0);
> 
> -spinlock_t notify_lock = SPIN_LOCK_UNLOCKED;
> +static spinlock_t notify_lock = SPIN_LOCK_UNLOCKED;
> static LIST_HEAD(notify_list);
> 
> static struct cn_dev cdev;
> 

Isn't this supposed to be "static DEFINE_SPINLOCK(notify_lock);" nowadays?

-- 
Dmitry
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to