Don Zickus <dzic...@redhat.com> writes: > + > +static const struct perf_evsel_str_handler handlers[] = { > + { "cpu/mem-loads,ldlat=30/pp", perf_c2c__process_load, }, > + { "cpu/mem-stores/pp", perf_c2c__process_store, },
The 30 magic number should probably be configurable. Using load-latency here rules out Atom, so at some point you would need to get rid of that. I suspect on most systems you should rather use p instead of pp to get the overhead down (before Haswell pp is expensive) > +static int perf_c2c__record(int argc, const char **argv) > +{ > + unsigned int rec_argc, i, j; > + const char **rec_argv; > + const char * const record_args[] = { > + "record", > + /* "--phys-addr", */ So is that needed or not? -Andi -- a...@linux.intel.com -- Speaking for myself only -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/