On Mon, 12 May 2014 15:51:13 -0700, Andi Kleen wrote:

[SNIP]
> +int test__aliases(void)

Just a nitpick.  Please use a more descriptive name for the testcase
like test__event_aliases().

> +{
> +     int err;
> +
> +     /* Download JSON files */
> +     /* XXX assumes perf is installed */
> +     /* For now user must manually download */
> +     if (0 && system("perf download > /dev/null") < 0) {
> +             /* Don't error out for this for now */
> +             fprintf(stderr, "perf download failed\n");
> +     }
> +
> +     evlist = perf_evlist__new();
> +     if (evlist == NULL)
> +             return -ENOMEM;
> +
> +     err = pmu_iterate_events(test_event);
> +     fprintf(stderr, " Parsed %d events :", num_events);
> +     if (failed > 0)
> +             fprintf(stderr, " %d events failed", num_events);

s/num_events/failed/ ?

And this kind of detailed information is usually printed when -v option
is given via pr_debug().

Thanks,
Namhyung


> +     perf_evlist__delete(evlist);
> +     return err;
> +}
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to