On Fri, Mar 11, 2005 at 07:34:46PM +1100, Peter Chubb wrote: > >>>>> "Greg" == Greg KH <[EMAIL PROTECTED]> writes: > > Greg> On Fri, Mar 11, 2005 at 02:37:17PM +1100, Peter Chubb wrote: > >> +/* + * The PCI subsystem is implemented as yet-another pseudo > >> filesystem, + * albeit one that is never mounted. + * This is its > >> magic number. + */ +#define USR_PCI_MAGIC (0x12345678) > > Greg> If you make it a real, mountable filesystem, then you don't need > Greg> to have any of your new syscalls, right? Why not just do that > Greg> instead? > > > The only call that would go is usr_pci_open() -- you'd still need > usr_pci_map()
see mmap(2) > , usr_pci_unmap() see munmap(2) In fact, both of the above can be done today from /proc/bus/pci/ right? > and usr_pci_get_consistent(). Hm, this one might be different. How about just opening and mmap a new file for the pci device for this? thanks, greg k-h - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/