On Wed, Aug 20, 2014 at 08:46:21AM +0900, Minchan Kim wrote:
> Hey Seth,
> 
> On Tue, Aug 19, 2014 at 09:46:28AM -0500, Seth Jennings wrote:
> > On Tue, Aug 19, 2014 at 04:54:45PM +0900, Minchan Kim wrote:
> > > zs_get_total_size_bytes returns a amount of memory zsmalloc
> > > consumed with *byte unit* but zsmalloc operates *page unit*
> > > rather than byte unit so let's change the API so benefit
> > > we could get is that reduce unnecessary overhead
> > > (ie, change page unit with byte unit) in zsmalloc.
> > > 
> > > Now, zswap can rollback to zswap_pool_pages.
> > > Over to zswap guys ;-)
> > 
> > I don't think that's how is it done :-/  Changing the API for a
> > component that has two users, changing one, then saying "hope you guys
> > change your newly broken stuff".
> 
> I don't get it. The zsmalloc's zs_zpool_total_size returns u64 with bytes,
> not pages so what's broken stuff you mentioned?
> 
> static u64 zs_zpool_total_size(void *pool)
> {
>     - return zs_get_total_size_bytes(pool);
>     + return zs_get_total_size(pool) << PAGE_SHIFT;
> }

Ah, that's my bad.  I forgot that there is zs_get_total_size() and
zs_pool_total_size() and that the zpool driver calls
zs_pool_total_size(), not zs_get_total_size().

Nevermind!

Seth

> 
> Thing I nudged to you is just you could roll back to pages count
> instead of bytes if zswap guys want it and I dont' want it myself
> for avoding unnecessary noise for this patchset's purpose.
> 
> > 
> > I know you would rather not move zram to the zpool API but doing so
> > would avoid situations like this.
> > 
> > Anyway, this does break the zpool API and by extension zswap, and that
> > needs to be addressed in this patch or we create a point in the commit
> > history where it is broken.
> > 
> > Quick glance:
> > - zpool_get_total_size() return type is u64 but this patch changes to
> > unsigned long.  Now mismatches between zbud and zsmalloc.
> 
> Nope. zs_zpool_total_size returns u64 with PAGE_SHIFT.
> 
> > - zbud_zpool_total_size needs to return pages, not bytes
> 
> It's up to you, not me.
> 
> > - as you noted s/pool_total_size/pool_pages/g in zswap.c plus
> >   modification to zswap_is_full()
> 
> I didn't mean it. Sorry for the confusing.
> If I miss your point, let me know it.
> 
> Thanks.
> 
> > 
> > Thanks,
> > Seth
> > 
> > > 
> > > Signed-off-by: Minchan Kim <minc...@kernel.org>
> > > ---
> > >  drivers/block/zram/zram_drv.c |  4 ++--
> > >  include/linux/zsmalloc.h      |  2 +-
> > >  mm/zsmalloc.c                 | 10 +++++-----
> > >  3 files changed, 8 insertions(+), 8 deletions(-)
> > > 
> > > diff --git a/drivers/block/zram/zram_drv.c b/drivers/block/zram/zram_drv.c
> > > index d00831c3d731..302dd37bcea3 100644
> > > --- a/drivers/block/zram/zram_drv.c
> > > +++ b/drivers/block/zram/zram_drv.c
> > > @@ -103,10 +103,10 @@ static ssize_t mem_used_total_show(struct device 
> > > *dev,
> > >  
> > >   down_read(&zram->init_lock);
> > >   if (init_done(zram))
> > > -         val = zs_get_total_size_bytes(meta->mem_pool);
> > > +         val = zs_get_total_size(meta->mem_pool);
> > >   up_read(&zram->init_lock);
> > >  
> > > - return scnprintf(buf, PAGE_SIZE, "%llu\n", val);
> > > + return scnprintf(buf, PAGE_SIZE, "%llu\n", val << PAGE_SHIFT);
> > >  }
> > >  
> > >  static ssize_t max_comp_streams_show(struct device *dev,
> > > diff --git a/include/linux/zsmalloc.h b/include/linux/zsmalloc.h
> > > index e44d634e7fb7..105b56e45d23 100644
> > > --- a/include/linux/zsmalloc.h
> > > +++ b/include/linux/zsmalloc.h
> > > @@ -46,6 +46,6 @@ void *zs_map_object(struct zs_pool *pool, unsigned long 
> > > handle,
> > >                   enum zs_mapmode mm);
> > >  void zs_unmap_object(struct zs_pool *pool, unsigned long handle);
> > >  
> > > -u64 zs_get_total_size_bytes(struct zs_pool *pool);
> > > +unsigned long zs_get_total_size(struct zs_pool *pool);
> > >  
> > >  #endif
> > > diff --git a/mm/zsmalloc.c b/mm/zsmalloc.c
> > > index a65924255763..80408a1da03a 100644
> > > --- a/mm/zsmalloc.c
> > > +++ b/mm/zsmalloc.c
> > > @@ -299,7 +299,7 @@ static void zs_zpool_unmap(void *pool, unsigned long 
> > > handle)
> > >  
> > >  static u64 zs_zpool_total_size(void *pool)
> > >  {
> > > - return zs_get_total_size_bytes(pool);
> > > + return zs_get_total_size(pool) << PAGE_SHIFT;
> > >  }
> > >  
> > >  static struct zpool_driver zs_zpool_driver = {
> > > @@ -1186,16 +1186,16 @@ void zs_unmap_object(struct zs_pool *pool, 
> > > unsigned long handle)
> > >  }
> > >  EXPORT_SYMBOL_GPL(zs_unmap_object);
> > >  
> > > -u64 zs_get_total_size_bytes(struct zs_pool *pool)
> > > +unsigned long zs_get_total_size(struct zs_pool *pool)
> > >  {
> > > - u64 npages;
> > > + unsigned long npages;
> > >  
> > >   spin_lock(&pool->stat_lock);
> > >   npages = pool->pages_allocated;
> > >   spin_unlock(&pool->stat_lock);
> > > - return npages << PAGE_SHIFT;
> > > + return npages;
> > >  }
> > > -EXPORT_SYMBOL_GPL(zs_get_total_size_bytes);
> > > +EXPORT_SYMBOL_GPL(zs_get_total_size);
> > >  
> > >  module_init(zs_init);
> > >  module_exit(zs_exit);
> > > -- 
> > > 2.0.0
> > > 
> > --
> > To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
> > the body of a message to majord...@vger.kernel.org
> > More majordomo info at  http://vger.kernel.org/majordomo-info.html
> > Please read the FAQ at  http://www.tux.org/lkml/
> 
> -- 
> Kind regards,
> Minchan Kim
> 
> --
> To unsubscribe, send a message with 'unsubscribe linux-mm' in
> the body to majord...@kvack.org.  For more info on Linux MM,
> see: http://www.linux-mm.org/ .
> Don't email: <a href=mailto:"d...@kvack.org";> em...@kvack.org </a>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to