* Hua Zhong ([EMAIL PROTECTED]) wrote:
>  >  int bt_sock_unregister(int proto)
> >  {
> > -   if (proto >= BT_MAX_PROTO)
> > +   if (proto < 0 || proto >= BT_MAX_PROTO)
> >             return -EINVAL;
> 
> Just curious: would it be better to say
> 
> if ((unsigned int)proto >= BT_MAX_PTORO)

the first check makes it painfully obvious what it's checking.  i think
it's a wash (-O2 seems to collapse to the same check), with a win for
readability.

thanks,
-chris
-- 
Linux Security Modules     http://lsm.immunix.org     http://lsm.bkbits.net
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to