On Fri, 2014-12-05 at 08:21 +0100, Julia Lawall wrote: > On Thu, 4 Dec 2014, Joe Perches wrote: > > It's generally nicer to replace embedded function names > > with "%s: ", __func__ > > > > pr_warn("%s: cipher_encrypt failed\n", __func__); > > Doing so may potentially allow some strings to be shared, thus saving a > little space. Perhaps not in this case, though.
It's not necessarily a code size savings in any case. It can be, but the real benefits are stylistic consistency and lack of mismatch between function name and message. If the code is refactored or copy/pasted into another function, a moderately common defect is not modifying the embedded function name in the message. There may be some smallish savings if ever these __func__ uses were converted to use %pf via some internal standardized mechanism. A negative to that approach is inlined functions would take the function name of the parent not keep the inlined function name. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/