On Sat, Feb 21, 2015 at 6:02 PM, Al Viro <v...@zeniv.linux.org.uk> wrote: > > I'm somewhat tempted to do this: > fs_inode -> d_inode > fs_inode_once ->d_inode_rcu (it's not quite ->d_revalidate()-only, there's > a bit in autofs ->d_manage() as well)
Ok, those at least match our existing naming logic (ie "d_inode()" would match what we did to "d_count()"). I'm not sure about d_inode_rcu(), for the simple reason that even when we're doing RCU walking, most of the time we have *not* used the ACCESS_ONCE() model, we instead end up just using the regular d_inode and then check the sequence count. I think. So the ACCESS_ONCE() thing is more special than just "done under RCU". It's more like "really special case done without any of the normal locking _or_ any of the normal RCU checks". That said, the overhead of using ACCESS_ONCE() is basically nil, so it's not like we couldn't just start doing more of them, and make it be more of a "any time we're under RCU" kind of thing. > dentry_inode -> something. d_opened_inode() might do, but I'm not sure - > still sounds a bit wrong to me. What it's about is "the actual fs object > behind this name, maybe from upper fs, maybe showing through from underlying > layer" Yeah, I think "d_backing_store_inode()" would probably be more along the lines, but that's a mouthful. Maybe shortened to "d_backing_inode()"? Linus -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/