* Andy Lutomirski <l...@amacapital.net> wrote:

> On Wed, Aug 5, 2015 at 11:27 AM, Steven Rostedt <rost...@goodmis.org> wrote:
> > On Wed, 5 Aug 2015 11:24:54 -0700
> > Andy Lutomirski <l...@amacapital.net> wrote:
> >
> >> On Wed, Aug 5, 2015 at 1:59 AM, Ingo Molnar <mi...@kernel.org> wrote:
> >> >
> >> > * Andy Lutomirski <l...@kernel.org> wrote:
> >> >
> >> >> --- a/arch/x86/kernel/process_64.c
> >> >> +++ b/arch/x86/kernel/process_64.c
> >> >> @@ -280,6 +280,10 @@ __switch_to(struct task_struct *prev_p, struct 
> >> >> task_struct *next_p)
> >> >>       unsigned fsindex, gsindex;
> >> >>       fpu_switch_t fpu_switch;
> >> >>
> >> >> +#ifdef CONFIG_DEBUG_ENTRY
> >> >> +     WARN_ON(this_cpu_read(irq_count));
> >> >> +#endif
> >> >
> >> > Please introduce a less noisy (to the eyes) version of this, something 
> >> > like:
> >> >
> >> >         WARN_ON_DEBUG_ENTRY(this_cpu_read(irq_count));
> >> >
> >> > or so, similar to WARN_ON_FPU().
> >>
> >> I can do that (or "DEBUG_ENTRY_WARN_ON"?  we seem to be inconsistent
> >> about ordering).
> >>
> >> Or would if (IS_ENABLED(CONFIG_DEBUG_ENTRY)) WARN_ON(...) be better?
> >>
> >
> > Does WARN_ON(IS_ENABLED(CONFIG_DEBUG_ENTRY) && this_cpu_read(irq_count))
> > work?
> 
> I'd be okay with it.  Ingo?

Yeah, that one is more compact than the #ifdef variant.

Thanks,

        Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to