On Sun, 21 Jul 2024 at 00:54, Kees Cook <k...@kernel.org> wrote: > > Based on feedback from Linus[1] and follow-up discussions, change the > suggested file naming for KUnit tests. > > Link: > https://lore.kernel.org/lkml/CAHk-=wgim6pNiGTBMhP8Kd3tsB7_JTAuvNJ=XYd3wPvvk=o...@mail.gmail.com/ > [1] > Signed-off-by: Kees Cook <k...@kernel.org> > --- > Cc: David Gow <david...@google.com> > Cc: Brendan Higgins <brendan.higg...@linux.dev> > Cc: Rae Moar <rm...@google.com> > Cc: John Hubbard <jhubb...@nvidia.com> > Cc: Jonathan Corbet <cor...@lwn.net> > Cc: Linus Torvalds <torva...@linux-foundation.org> > Cc: linux-kselftest@vger.kernel.org > Cc: kunit-...@googlegroups.com > Cc: linux-...@vger.kernel.org > Cc: linux-ker...@vger.kernel.org > Cc: linux-harden...@vger.kernel.org > ---
Thanks again for dealing with this, Kees. > Documentation/dev-tools/kunit/style.rst | 25 +++++++++++++++---------- > 1 file changed, 15 insertions(+), 10 deletions(-) > > diff --git a/Documentation/dev-tools/kunit/style.rst > b/Documentation/dev-tools/kunit/style.rst > index b6d0d7359f00..1538835cd0e2 100644 > --- a/Documentation/dev-tools/kunit/style.rst > +++ b/Documentation/dev-tools/kunit/style.rst > @@ -188,15 +188,20 @@ For example, a Kconfig entry might look like: > Test File and Module Names > ========================== > > -KUnit tests can often be compiled as a module. These modules should be named > -after the test suite, followed by ``_test``. If this is likely to conflict > with > -non-KUnit tests, the suffix ``_kunit`` can also be used. > - > -The easiest way of achieving this is to name the file containing the test > suite > -``<suite>_test.c`` (or, as above, ``<suite>_kunit.c``). This file should be > -placed next to the code under test. > +Whether a KUnit test is compiled as a separate module or via an > +``#include`` in a core kernel source file, the file should be named > +after the test suite, followed by ``_kunit``, and live in a ``tests`` > +subdirectory to avoid conflicting with regular modules (e.g. if "foobar" > +is the core module, then "foobar_kunit" is the KUnit test module) or the > +core kernel source file names (e.g. for tab-completion). Many existing > +tests use a ``_test`` suffix, but this is considered deprecated. I think John's updated version here is better. Personally, I'd rather the bit about module names lead here, as I think that's the part most likely to cause actual issues, and the source file name bit is more of a "here are problems to avoid, and sensible defaults which avoid them" than "here's an utterly inviolable rule". Maybe: ``` KUnit tests are often compiled as a separate module. To avoid conflicting with regular modules, KUnit modules should be named after the test suite, followed by ``_kunit`` (e.g. if "foobar" is the core module, then "foobar_kunit" is the KUnit test module). Test source files, whether compiled as a separate module or an ``#include`` in another source file, are best kept in a ``tests/ subdirectory to not conflict with other source files (e.g. for tab-completion). Note that the ``_test`` suffix has also been used in some existing tests. The ``_kunit`` suffix is preferred, as it makes the distinction between KUnit and non-KUnit tests clearer. ``` (But this is all largely bikeshedding at this point. As long as we end up describing the sensible defaults, and don't paint ourselves (and subsystem maintainers) into a corner, either should work. > + > +So for the common case, name the file containing the test suite > +``tests/<suite>_kunit.c``. The ``tests`` directory should be placed at > +the same level as the code under test. For example, tests for > +``lib/string.c`` live in ``lib/tests/string_kunit.c``. > > If the suite name contains some or all of the name of the test's parent > -directory, it may make sense to modify the source filename to reduce > redundancy. > -For example, a ``foo_firmware`` suite could be in the ``foo/firmware_test.c`` > -file. > +directory, it may make sense to modify the source filename to reduce > +redundancy. For example, a ``foo_firmware`` suite could be in the > +``tests/foo/firmware_kunit.c`` file. I think that this should be ``foo/tests/firmware_kunit.c``. I'd even be okay with ``foo/tests/firmware.c``, as the module name needs manually updating in the makefile anyway, where it should either be ``foo_firmware_kunit``, or included in a larger ``foo_kunit`` module. -- David
smime.p7s
Description: S/MIME Cryptographic Signature