Hi Mike,

Sorry for not answering your previous post...

On Fri, 1 May 2009 20:30:48 -0500 (CDT), Mike Isely wrote:
> Jean:
> 
> I have another idea that I think you'll like.  I'm putting the finishing 
> touches on the patch right now.
> 
> What I have implements correct ir_video loading for the pvrusb2 driver.  
> It also includes a lookup table (though with only 1 entry right now) to 
> determine the proper I2C address and I use i2c_new_device() now instead 
> of i2c_new_probed_device().  I've also renamed things to be "ir_video" 
> everywhere instead of ir_kbd_i2c as was discussed.

This sounds really good. The more we know about cards, the less we have
to probe, the better.

> In particular the disable option is there like before, but now it's 
> called disable_autoload_ir_video.

Call me a nitpicker, but once again, there's nothing autoloading here
so this name is a little confusing.

> So far this is exactly what I was saying before.  But I'm also making 
> one more change: the disable_autoload_ir_video option default value will 
> - for now - be 1, i.e. everything above I just described starts off 
> disabled.  This means that the entire patch can be pulled _right_ _now_ 
> without breaking anything at all, because the outward behavior is still 
> unchanged.

Yes, this is correct, and will obviously make merging easier. Thanks
for coming up with this.

> Then, when you're ready to bring your stuff in, all you need to do is 
> include a 1-line change to pvrusb2-i2c-core.c to switch the default 
> value of disable_autoload_ir_video back to 0, which now enables all the 
> corresponding pvrusb2 changes that you need to avoid any breakage inside 
> my driver.  Just to be absolutely crystal clear, here's the change you 
> will be able to do once these changes are in:
> 
> diff -r 8d2e1361520c linux/drivers/media/video/pvrusb2/pvrusb2-i2c-core.c
> --- a/linux/drivers/media/video/pvrusb2/pvrusb2-i2c-core.c    Fri May 01 
> 20:23:39 2009 -0500
> +++ b/linux/drivers/media/video/pvrusb2/pvrusb2-i2c-core.c    Fri May 01 
> 20:24:23 2009 -0500
> @@ -43,7 +43,7 @@
>  module_param_array(ir_mode, int, NULL, 0444);
>  MODULE_PARM_DESC(ir_mode,"specify: 0=disable IR reception, 1=normal IR");
>  
> +static int pvr2_disable_ir_video;
> -static int pvr2_disable_ir_video = 1;
>  module_param_named(disable_autoload_ir_video, pvr2_disable_ir_video,
>                  int, S_IRUGO|S_IWUSR);
>  MODULE_PARM_DESC(disable_autoload_ir_video,
> 
> So with all this, what I am setting up right now will cause no harm to 
> the existing situation, requires no actual messing with module options, 
> and once you're reading, just include the 1-line change above and you're 
> set.  There's no "race here", no gap in IR handling.

This is all fine with me. Well, at this point, pretty much everything
which pushes the ir-kbd-i2c conversion forward is fine with me, as it
seems to be kind of stuck. The theory was that we would use the 2.6.31
development cycle to merge lirc and then convert ir-kbd-i2c, however I
don't see much happening in this direction, while we're probably 5
weeks away from the next merge window or so.

Mauro, please pull Mike's pvrusb2-dev work as soon as he asks you to do
so. Then I'll rebase my own patch set and send it again.

Thanks,
-- 
Jean Delvare
--
To unsubscribe from this list: send the line "unsubscribe linux-media" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to