On Mon, Oct 2, 2017 at 10:40 AM, Arnd Bergmann <a...@arndb.de> wrote: > > void fortify_panic(const char *name) __noreturn __cold; > + > +/* work around GCC PR82365 */ > +#if defined(CONFIG_KASAN) && !defined(__clang__) && GCC_VERSION <= 80000 > +#define fortify_panic(x) \ > + do { \ > + asm volatile(""); \ > + fortify_panic(x); \ > + } while (0) > +#endif
This broke the build for the fortify_panic() definition in lib/string.c which clashes with the macro. I've fixed it locally by renaming it to __fortify_panic, but won't post the fixed version until I get some feedback on the basic approach. Arnd