The > ARRAY_SIZE() should be >= ARRAY_SIZE().  Also this is a slightly
unrelated cleanup but I replaced the magic numbers 30 and 25 with
ARRAY_SIZE() - 1.

Fixes: 363d79f1d5bd ('[media] tw686x: Don't go past array')
Signed-off-by: Dan Carpenter <dan.carpen...@oracle.com>

diff --git a/drivers/media/pci/tw686x/tw686x-video.c 
b/drivers/media/pci/tw686x/tw686x-video.c
index d2a0147..7b87f27 100644
--- a/drivers/media/pci/tw686x/tw686x-video.c
+++ b/drivers/media/pci/tw686x/tw686x-video.c
@@ -64,12 +64,12 @@ static unsigned int tw686x_fields_map(v4l2_std_id std, 
unsigned int fps)
        unsigned int i;
 
        if (std & V4L2_STD_525_60) {
-               if (fps > ARRAY_SIZE(std_525_60))
-                       fps = 30;
+               if (fps >= ARRAY_SIZE(std_525_60))
+                       fps = ARRAY_SIZE(std_525_60) - 1;
                i = std_525_60[fps];
        } else {
-               if (fps > ARRAY_SIZE(std_625_50))
-                       fps = 25;
+               if (fps >= ARRAY_SIZE(std_625_50))
+                       fps = ARRAY_SIZE(std_625_50) - 1;
                i = std_625_50[fps];
        }
 
--
To unsubscribe from this list: send the line "unsubscribe linux-media" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to