Patch set 8/12

[PATCH] mmc: core: add comment why sdio_reset is done at init time
sdio_reset sends a CMD52 to reset the sdio card.  This is
highly recommended for sdio cards being reinitialized.  Since
we do not know if the card is being reinitialized we just send
the command.  SD/eMMC cards are supposed to ignore the CMD
before the CMD0.  Document why we are doing this.

[PATCH] mmc: mmc.c check if mmc cards < 2GB do sector addressing

Some TOSHIBA MMC cards only support sector addressing
even though the size is < 2GB.  According to JEDEC
Spec JESD84-A441-1 the ocr register (bits 30, 29)
determine byte/sector mode.  Use them.


[PATCH] mmc: rename ddr to uhs in ios structure to indicate usage

uhs mode comprises dual data rate, single data rate options
such as ddr_1_8v as well as sdr50 and sdr104
ddr name changed to indicate its true usage

--
To unsubscribe from this list: send the line "unsubscribe linux-mmc" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to