On Tue, Sep 30, 2014 at 5:07 PM, Javier Martinez Canillas
<jav...@dowhile0.org> wrote:
> On Tue, Sep 30, 2014 at 4:05 PM, Linus Walleij <linus.wall...@linaro.org> 
> wrote:

>> @@ -316,6 +317,8 @@ int mmc_gpiod_request_cd(struct mmc_host *host, const 
>> char *con_id,
>>                         return ret;
>>         }
>>
>> +       *gpio_invert = gpiod_is_active_low(desc);
>> +
>
> The old code set gpio_inv_cd if (!(flags & OF_GPIO_ACTIVE_LOW)) so the
> above should be:
>
> *gpio_invert = !gpiod_is_active_low(desc);

Argh, done it like this in v2, but isn't that variable name a lie then?
If it's active low then it's inverted, but if it's not active low it's not
inverted right...

Sigh, atleast we have restored the semantics, but maybe we need
to comb over this again.

Yours,
Linus Walleij
--
To unsubscribe from this list: send the line "unsubscribe linux-mmc" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to