From: Carlo Caione <ca...@endlessm.com>

Add a helper function to check if an opcode is a sd-io-* opcode.

Signed-off-by: Carlo Caione <ca...@endlessm.com>
---
 drivers/mmc/core/sdio_ops.h | 5 +++++
 1 file changed, 5 insertions(+)

diff --git a/drivers/mmc/core/sdio_ops.h b/drivers/mmc/core/sdio_ops.h
index e4b5ceb..9b614b2 100644
--- a/drivers/mmc/core/sdio_ops.h
+++ b/drivers/mmc/core/sdio_ops.h
@@ -26,5 +26,10 @@ static inline bool mmc_is_rw_io_op(u32 opcode)
        return opcode == SD_IO_RW_DIRECT || opcode == SD_IO_RW_EXTENDED;
 }
 
+static inline bool mmc_is_io_op(u32 opcode)
+{
+       return mmc_is_rw_io_op(opcode) || opcode == SD_IO_SEND_OP_COND;
+}
+
 #endif
 
-- 
2.5.0

--
To unsubscribe from this list: send the line "unsubscribe linux-mmc" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to