On 2026/8/24 下午4:45, Huacai Chen wrote:
Hi, Tiezhu,

On Thu, Aug 20, 2026 at 8:50 PM Tiezhu Yang <[email protected]> wrote:

The helper function is_mapping_symbol() historically checks for both
local labels prefixed with ".L" or "L0" and mapping symbols prefixed
with "$".

Rename it to is_ignored_kernel_symbol() to better reflect this actual
behavior and scope, preventing conceptual confusion.
I think is_ignored_symbol() is enough, no "kernel" needed.

Hi Huacai,

Using is_ignored_kernel_symbol() was suggested by Petr [1] to maintain
consistency with the existing naming convention in tools/perf.

For me, either is_ignored_kernel_symbol() or is_ignored_symbol() is
fine. I will leave it to Petr to make the final call on this.

[1] https://lore.kernel.org/loongarch/[email protected]/

Thanks,
Tiezhu


Reply via email to