Hi Koen, > -----Original Message----- > From: Koen Kooi [mailto:[EMAIL PROTECTED] > Sent: Thursday, April 24, 2008 4:20 PM > To: linux-omap@vger.kernel.org > Cc: Syed Mohammed, Khasim > Subject: [PATCH 1/1] ARM: OMAP: omap3beagle: register USB interfaces > > From 101e01552974e9ce7b4bf26aa5e4a203130b6dfd Mon Sep 17 00:00:00 2001 > From: Koen Kooi <[EMAIL PROTECTED]> > Date: Thu, 24 Apr 2008 12:28:53 +0200 > Subject: [PATCH] omap3beagle: register USB interfaces > > Signed-off-by: Koen Kooi <[EMAIL PROTECTED]> > --- > arch/arm/mach-omap2/Makefile | 3 ++- > arch/arm/mach-omap2/board-omap3beagle.c | 1 + > include/asm-arm/arch-omap/board-omap3beagle.h | 1 + > 3 files changed, 4 insertions(+), 1 deletions(-) > > diff --git a/arch/arm/mach-omap2/Makefile b/arch/arm/mach-omap2/Makefile > index c37df1a..10607cf 100644 > --- a/arch/arm/mach-omap2/Makefile > +++ b/arch/arm/mach-omap2/Makefile > @@ -37,7 +37,8 @@ obj-$(CONFIG_MACH_OMAP_3430SDP) += board- > 3430sdp.o \ > board-3430sdp-flash.o > obj-$(CONFIG_MACH_OMAP3EVM) += board-omap3evm.o > obj-$(CONFIG_MACH_OMAP3_BEAGLE) += board-omap3beagle.o \ > - board-sdp-hsmmc.o > + board-sdp-hsmmc.o \ > + board-3430sdp-usb.o > obj-$(CONFIG_MACH_OMAP_APOLLON) += board-apollon.o \ > board-apollon-mmc.o \ > board-apollon-keys.o > diff --git a/arch/arm/mach-omap2/board-omap3beagle.c b/arch/arm/mach- > omap2/board-omap3beagle.c > index c03bb26..3e14b6b 100644 > --- a/arch/arm/mach-omap2/board-omap3beagle.c > +++ b/arch/arm/mach-omap2/board-omap3beagle.c > @@ -66,6 +66,7 @@ static void __init omap3_beagle_init(void) > omap_board_config_size = ARRAY_SIZE(omap3_beagle_config); > omap_serial_init(); > sdp_mmc_init(); > + sdp3430_usb_init(); > } > > arch_initcall(omap3_beagle_i2c_init); > diff --git a/include/asm-arm/arch-omap/board-omap3beagle.h b/include/ > asm-arm/arch-omap/board-omap3beagle.h > index 782e2e5..5f78621 100644 > --- a/include/asm-arm/arch-omap/board-omap3beagle.h > +++ b/include/asm-arm/arch-omap/board-omap3beagle.h > @@ -30,6 +30,7 @@ > #define __ASM_ARCH_OMAP3_BEAGLE_H > > extern void sdp_mmc_init(void); > +extern void sdp3430_usb_init(void); >
I think we are neglecting David B's comments, As suggested by David, we have to rename sdp3430 to some thing common and move these definitions out of the board dependent files -or rename these specific to beagle something like omap3beagle_usb_init(). Same thing is applicable to mmc and other common interfaces. Regards, Khasim -- To unsubscribe from this list: send the line "unsubscribe linux-omap" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html