> -----Original Message----- > From: Mike Rapoport [mailto:mike.rapop...@gmail.com] > Sent: Friday, November 06, 2009 2:47 AM > To: Aggarwal, Anuj > Cc: linux-omap@vger.kernel.org; broo...@opensource.wolfsonmicro.com; > l...@slimlogic.co.uk > Subject: Re: [PATCH 5/5] Regulator: Renaming the supplies used in MMC > driver > > On Thu, Nov 5, 2009 at 6:39 PM, Anuj Aggarwal <anuj.aggar...@ti.com> > wrote: > > Supply names are renamed from vmmc -> mmc and vmmc_aux -> mmc_aux. > > This is done to have simple supply names both in the driver > > and in the board-evm file. > > > > Signed-off-by: Anuj Aggarwal <anuj.aggar...@ti.com> > > --- > > arch/arm/mach-omap2/mmc-twl4030.c | 6 +++--- > > 1 files changed, 3 insertions(+), 3 deletions(-) > > > > diff --git a/arch/arm/mach-omap2/mmc-twl4030.c b/arch/arm/mach- > omap2/mmc-twl4030.c > > index 3403914..af3b1be 100644 > > --- a/arch/arm/mach-omap2/mmc-twl4030.c > > +++ b/arch/arm/mach-omap2/mmc-twl4030.c > > @@ -109,9 +109,9 @@ static int twl_mmc_late_init(struct device *dev) > > > > hsmmc[i].mmc = mmc; > > > > - reg = regulator_get(dev, "vmmc"); > > + reg = regulator_get(dev, "mmc"); > > It will break all existing OMAP3 boards. [Aggarwal, Anuj] This was done to have the same naming conventions across the board. I could not find an extra "v" in supply names except MMC. Hence modified this. Regulator supply names should be simple and easy to understand. I can revert this change or change the dependent board files for SDP/LDP etc. What do you suggest? > > > if (IS_ERR(reg)) { > > - dev_dbg(dev, "vmmc regulator > missing\n"); > > + dev_dbg(dev, "mmc regulator missing\n"); > > /* HACK: until fixed.c regulator is > usable, > > * we don't require a main regulator > > * for MMC2 or MMC3 > > @@ -126,7 +126,7 @@ static int twl_mmc_late_init(struct device *dev) > > mmc->slots[0].ocr_mask = > mmc_regulator_get_ocrmask(reg); > > > > /* allow an aux regulator */ > > - reg = regulator_get(dev, "vmmc_aux"); > > + reg = regulator_get(dev, "mmc_aux"); > > ditto. > > > hsmmc[i].vcc_aux = IS_ERR(reg) ? NULL : reg; > > > > /* UGLY HACK: workaround regulator framework > bugs. > > -- > > 1.6.2.4 > > > > -- > > To unsubscribe from this list: send the line "unsubscribe linux-omap" in > > the body of a message to majord...@vger.kernel.org > > More majordomo info at http://vger.kernel.org/majordomo-info.html > > > > > > -- > Sincerely Yours, > Mike.
-- To unsubscribe from this list: send the line "unsubscribe linux-omap" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html