On Tuesday 01 June 2010 09:38:07 ext Jarkko Nikula wrote: > On Mon, 31 May 2010 14:57:22 +0300 > > Peter Ujfalusi <peter.ujfal...@nokia.com> wrote: > > On Monday 31 May 2010 13:00:21 ext Liam Girdwood wrote: > > > > ... > > > > > > +static int hw_rule_bsize_by_channels(struct snd_pcm_hw_params > > > > *params, + struct snd_pcm_hw_rule > > > > *rule) > > > > +{ > > > > + struct snd_interval *bs = hw_param_interval(params, > > > > + SNDRV_PCM_HW_PARAM_BUFFER_SIZE); > > > > + struct snd_interval *c = hw_param_interval(params, > > > > + SNDRV_PCM_HW_PARAM_CHANNELS); > > > > > > Best to make these variable names more meaningful. > > > > Sure, I can change that. I have picked these, since all code, which adds > > hw_rule (and the writing an ALSA driver manual) are using variables like > > this. In Here I mean: > > bs == Buffer Size > > c == Channels > > Change also function names. They should start with omap_mcbsp_. > > hw_rule_bsize_by_channels > hw_rule_psize_by_channels > -> > omap_mcbsp_(calc_max_bufsize, rule_max_buf, or something) > omap_mcbsp_(calc_max_periodsize)
Oh yes, they should start with omap_mcbsp_ I'll change them too. I like the following naming: omap_mcbsp_hwrule_min_buffersize() omap_mcbsp_hwrule_max_periodsize() Also, I think there is no point to limit the lower period size in threshold mode to 32, so I will remove that as well I think. I'll wait couple of hours for comments, and resend the series. Thanks, Péter -- To unsubscribe from this list: send the line "unsubscribe linux-omap" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html